SMF 2.1 RC1 Notification [Bildirim] sorunu

Started by orhan, Feb 10, 2019, 11:37 am

Previous topic - Next topic

orhan

Update:

A significant bug has been found in RC1 that prevents alerts and notification messages from being sent. A fix for this has already been included in the code on GitHub and will be available in RC2.

In the meantime, users of RC1 can fix this issue themselves by manually editing cron.php, which is located in the root folder of your forum (i.e., the same folder as index.php and SSI.php).

In cron.php, find these two lines of code (they are near the start of the file):

Find
Code Select
define('SMF', 'BACKGROUND');
define('FROM_CLI', empty($_SERVER['REQUEST_METHOD']));

Now replace them with the following:

Code Select
define('SMF', 'BACKGROUND');
define('SMF_VERSION', '2.1 RC1');
define('SMF_FULL_VERSION', 'SMF ' . SMF_VERSION);
define('SMF_SOFTWARE_YEAR', '2019');
define('FROM_CLI', empty($_SERVER['REQUEST_METHOD']));

Güncelleme

RC1'de, uyarıların ve bildirim mesajlarının gönderilmesini önleyen önemli bir hata bulundu. Bunun için bir düzeltme GitHub koduna zaten eklenmiş ve RC2'de mevcut olacak.

Bu arada, RC1 kullanıcıları, forumunuzun kök klasöründe bulunan cron.php dosyasını el ile düzenleyerek bu sorunu kendi başlarına çözebilirler.

Bul:

Code Select
define('SMF', 'BACKGROUND');
define('FROM_CLI', empty($_SERVER['REQUEST_METHOD']));

Değiştir:

Code Select
define('SMF', 'BACKGROUND');
define('SMF_VERSION', '2.1 RC1');
define('SMF_FULL_VERSION', 'SMF ' . SMF_VERSION);
define('SMF_SOFTWARE_YEAR', '2019');
define('FROM_CLI', empty($_SERVER['REQUEST_METHOD']));

replikacep

Code Select
Type of error: Critical
The database value you're trying to insert does not exist: request_list
Function: execute
 /home/....../public_html/Sources/tasks/GroupAct-Notify.php (Line 40)

bu tip hata alanlar  admin panel hata günlügünde


tablo :  smf_background_tasks


        toplo  içinde  bulun  silin  : 
Code Select
  (2603, '$sourcedir/tasks/GroupAct-Notify.php', 'GroupAct_Notify_Background', 'false', 1549812182);

bu sorun beta 3 den RC 1 e geçenlerde görünür